HORIZON HASKELLDocslts/ghc-10.0.x77a86622026-10-31Search packagesCtrl K
Theme: |

GHC 10.0.0.20260917 · lts/ghc-10.0.x · 77a8662 · 2026-10-31

Moduletls-2.4.9Haskell2010

Network.TLS.Extra.Cipher

Contents
  1. Cipher suite
  2. Individual ciphers
  3. RFC 5288
  4. RFC 8446
  5. RFC 5289
  6. RFC 7251
  7. RFC 7905
  8. Deprecated names
  9. RFC 5288
  10. RFC 8446
  11. RFC 5289
  12. RFC 7251
  13. RFC 7905
Synopsis
  • Packagetls-2.4.9
  • Exports43
  • LanguageHaskell2010
  • LicenceBSD-3-Clause
  • SourceCipher.hs

Cipher suite

valueciphersuite_default :: [Cipher]

All AES and ChaCha20-Poly1305 ciphers supported ordered from strong to weak. This choice of ciphersuites should satisfy most normal needs. For otherwise strong ciphers we make little distinction between AES128 and AES256, and list each but the weakest of the AES128 ciphers ahead of the corresponding AES256 ciphers.

AEAD ciphers with equivalent security properties are ordered based on CPU hardware-acceleration support. If this dynamic runtime behavior is not desired, use ciphersuite_default_det instead.

valueciphersuite_all :: [Cipher]

The default ciphersuites + some not recommended last resort ciphers.

AEAD ciphers with equivalent security properties are ordered based on CPU hardware-acceleration support. If this dynamic runtime behavior is not desired, use ciphersuite_all_det instead.

valueciphersuite_strong :: [Cipher]

The strongest ciphers supported. For ciphers with PFS, AEAD and SHA2, we list each AES128 variant after the corresponding AES256 and ChaCha20-Poly1305 variants. For weaker constructs, we use just the AES256 form.

AEAD ciphers with equivalent security properties are ordered based on CPU hardware-acceleration support. If this dynamic runtime behavior is not desired, use ciphersuite_strong_det instead.

valueciphersuite_dhe_rsa :: [Cipher]

DHE-RSA cipher suite. This only includes ciphers bound specifically to DHE-RSA so TLS 1.3 ciphers must be added separately.

Individual ciphers

RFC 5288

RFC 8446

RFC 5289

RFC 7251

RFC 7905

Deprecated names

RFC 5288

RFC 8446

RFC 5289

RFC 7251

RFC 7905