HORIZON HASKELLDocslts/ghc-10.0.x77a86622026-10-31Search packagesCtrl K
Theme: |

GHC 10.0.0.20260917 · lts/ghc-10.0.x · 77a8662 · 2026-10-31

Package0.13Cryptography

jose

JSON Object Signing and Encryption (JOSE) and JSON Web Token (JWT) library

Modules

Description

Implementation of JSON Object Signing and Encryption (JOSE) and JSON Web Token (JWT; RFC 7519).

The JSON Web Signature (JWS; RFC 7515) implementation is complete.

EdDSA signatures (RFC 8037) and secp256k1 (RFC 8812) are supported.

JWK Thumbprint (RFC 7638) is supported.

JSON Web Encryption (JWE; RFC 7516) is not yet implemented.

The ECDSA implementation is vulnerable to timing attacks and should only be used for verification.

Depends on

16 packages

Used by in this set · 2